• 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Release] MW3 Server Addon
Hello guys, I am trying to configure a Quickscope server.

But when I set as weapon default classes with L118a or MSR (iw5_l96a1 / iw5_msr) when the weapon shoot the first shot the server crashes.

With other sniper rifles there is no problem.
addon.dll version 1.413 (also tested with 1.414) without any plugin.

The mw3 server version is the current one: v 1.9.388
I have a dedicated server and also tested with my Windows PC, still the same crashes.
As soon as I shoot with L118a or MSR the server windows closes.

Any idea how to fix it?
Thanks

Edit: More weapons crash the server (sniper, shotgun), all manual action.
MSR, L118A, SPAS12, KSG, WINCHESTER 1887
  Reply
Hello guys after some works I finally fixed the addon for Bold Action server crash on MW3 1.9.388.
I also fixed the Extensions.cs class (with all new offset) which allow to make boxes and spawn models.

All the files are also available on github, if I found some spare time I can publish all the fixed plugin too on that repository.

https://github.com/xenio/mw3-addon

Thanks to Casper for his support.
Xenio.


Attached Files
.zip   addon-mw3-v19388.zip (Size: 207.68 KB / Downloads: 37)
  Reply
(10-13-2019, 11:25)xenio Wrote: Hello guys, I am trying to configure a Quickscope server.

But when I set as weapon default classes with L118a or MSR (iw5_l96a1 / iw5_msr) when the weapon shoot the first shot the server crashes.

With other sniper rifles there is no problem.
addon.dll version 1.413 (also tested with 1.414) without any plugin.

The mw3 server version is the current one: v 1.9.388
I have a dedicated server and also tested with my Windows PC, still the same crashes.
As soon as I shoot with L118a or MSR the server windows closes.

Any idea how to fix it?
Thanks

Edit: More weapons crash the server (sniper, shotgun), all manual action.
MSR, L118A, SPAS12, KSG, WINCHESTER 1887

I got the same problem on my promod server, how to fix it ? <.< which file we need to replace?
  Reply
Hello everyone!

So i ve been facing this problem quite a while now...

When i try to add this command to my OnSay section:

bool suicide = Message == "!kill";
if (suicide)
{
PlayerSuicide(Client.ClientNum);
TellClient(Client.ClientNum, "^:Console: ^7You have committed ^1Suicide", true);
return ChatType.ChatNone;
}

nothing happens, except in chat the Client writes down !kill, without the actual code to trigger.

If anybody got something please share or help
Thank you!
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  [Release] ADDON + BOXES MW3 v1.9.388 xenio 0 700 01-04-2020, 12:39
Last Post: xenio
  How to set up your own modded server with server addon for supernoobs JariZ 133 72,654 03-04-2018, 16:14
Last Post: h1dexyz
  [Tutorial] How to install plugins to your MW3 Server JariZ 24 25,371 07-17-2017, 07:54
Last Post: syrvvp
  [Release] Linux Fix for Server Addon zxz0O0 54 20,665 05-21-2016, 14:18
Last Post: clacki
  Nukems MW3 Addon doesn't exist now what? graphix2004 3 2,237 03-19-2016, 22:17
Last Post: CashMoneyMedia
Video How to compile MW3 server plugins for supernoobs JariZ 57 30,714 07-24-2015, 14:06
Last Post: graphix2004
  Help 'Server rejected our connection request' blxw 0 1,522 02-15-2015, 21:58
Last Post: blxw
  Server cannot conect to service s.j-rez 3 2,124 07-14-2014, 18:54
Last Post: Casper
  Server crash claassic 0 1,373 06-20-2014, 19:54
Last Post: claassic
  Help Server crashes with addon. Reindeer 4 2,537 06-19-2014, 08:55
Last Post: Reindeer

Forum Jump:


Users browsing this thread: 1 Guest(s)