• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Request liberator 1.2
#1
Guys i need a liberator for 1.2.208 build
can anyone help me??HuhHuhHuh
thanks!!BlushBlush
  Reply
#2
its called liberation and the latest version is 1.07

next time use the board search funtion
http://www.itsmods.com/forum/Thread-Rele...-1-06.html

and yes the 1.06 version works with the patch 1.2.208

if you plan to play on the latest build, guess its v1.2.193, then you need Liberation 1.07
  Reply
#3
thnx bro
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)