• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Help] D3D9.dll is incompatible with Windows 8
#1
Sad 
Hello, I have MW3 steam edition, and I want to add in my dedicated server the Nukem's addon. So I've download it and paste all of files in my MW3 dedicated server's directory. But when I launch file named "iw5mp_server.exe", I get error 0xc0000142. So I've read all thread who speaking about this or the addon, but every sort of 'fix' like rename the d3d9.dll to x3x9.dll after have changed line in iw5mp_server.exe with an hex editor, all don't change anything... Have you a d3d9.dll fixed for windows 8 or any other idea to fix this ?

PS: And Sorry for my English if you don't understand, I'm French.
  Reply
#2
I run a test server on Win 8 and it all runs fine. I didn't even have to change any files. You can try my d3d9.dll file

Casper Chicken
~FYANB~ Servers Website

Primary Account:
[Image: 76561198070236721.png]
Secondary Account:
[Image: 76561198096107676.png]
Third Account:
[Image: 76561198164751656.png]
[-] The following 1 user says Thank You to Casper for this post:
  • Creased
  Reply
#3
Smile 
Thanks you very much I will test it tomorrow Smile

It's strange this don't change anything I still getting 0xc0000142 error ... Can you share me your iw5mp_server.exe and your addon ?
Actually I use the 1.9.461 version of the Dedicated server maybe that is a cause of the problem ?

PS: I know my English is bad Smile
  Reply
#4
(11-01-2013, 03:12)Creased Wrote: Thanks you very much I will test it tomorrow Smile

It's strange this don't change anything I still getting 0xc0000142 error ... Can you share me your iw5mp_server.exe and your addon ?
Actually I use the 1.9.461 version of the Dedicated server maybe that is a cause of the problem ?

PS: I know my English is bad Smile

I don't think thats why. I'm not really sure. Huh

Casper Chicken
~FYANB~ Servers Website

Primary Account:
[Image: 76561198070236721.png]
Secondary Account:
[Image: 76561198096107676.png]
Third Account:
[Image: 76561198164751656.png]
  Reply
#5
I'm running Windows 8.1 and get the same error message. Will see if I can debug and find the cause.

EDIT - OllyDbg and IDA didn't seem to like iw5mp_server.exe, no idea why. Tried it under WinDbg and it worked fine, not sure what's going on (I had to make WinDbg suppress/ignore access violations inside RtlFreeHeap).

EDIT #2 - I've found the cause, it's to do with the module cloaking functions, I'll see if I can make a patched version.

EDIT #3 - Now it's to do with d3d9.dll.

EDIT #4 - Alright, I made a fix, simply place the executable next to iw5mp_server.exe and then run it. It acts as a simple debugger to swallow the early exceptions and patch the troublesome cloaking function.

Download:
http://www.itsmods.com/forum/Thread-Rele...pid=104346
[Image: 30xhrep.png]

A casual conversation between barata and I about Nukem.
[-] The following 4 users say Thank You to master131 for this post:
  • barata, Creased, Nekochan, surtek
  Reply
#6
I've tried the patch over and over again but it doesn't work Huh. I also have Windows 8.1 but it always says "Nothing happened in 5 seconds, Patch was unsuccessful", then it closes Dodgy. Could someone help me. when is run as a bat the cmd window closes after a second and nothing runs. But when I launch file named "iw5mp_server.exe,I get the same error
Quote: I get error 0xc0000142
.

Could Someone help me Sad
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)